// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)"(wert|wert2)"\s*:\s*{\s*"WERTNAME"\s*:\s*"?([^,"]+)"#).unwrap();
let string = "\"wert\":{\"WERTNAME\":XXXXXXX,
\"wert2\":{\"WERTNAME\":XXXXXX,
\"wert2\":{\"WERTNAME\":\"XXXXXX\",
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}