package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)"(wert|wert2)"\s*:\s*{\s*"WERTNAME"\s*:\s*"?([^,"]+)`)
var str = `"wert":{"WERTNAME":XXXXXXX,
"wert2":{"WERTNAME":XXXXXX,
"wert2":{"WERTNAME":"XXXXXX",
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}