using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(wert|wert2)""\s*:\s*{\s*""WERTNAME""\s*:\s*""?([^,""]+)";
string input = @"""wert"":{""WERTNAME"":XXXXXXX,
""wert2"":{""WERTNAME"":XXXXXX,
""wert2"":{""WERTNAME"":""XXXXXX"",
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}