const regex = /"(wert|wert2)"\s*:\s*{\s*"WERTNAME"\s*:\s*"?([^,"]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(wert|wert2)"\\s*:\\s*{\\s*"WERTNAME"\\s*:\\s*"?([^,"]+)', 'gmi')
const str = `"wert":{"WERTNAME":XXXXXXX,
"wert2":{"WERTNAME":XXXXXX,
"wert2":{"WERTNAME":"XXXXXX",
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}