#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<[^>]+class="container"[^>]*>([^<]+)<\/[^>]+>"
Local $sString = "<div class="container">div</div>" & @CRLF & _
"<span contenteditable class="container" id="a_span_element">nope!</span>" & @CRLF & _
"<span>Not matching</span>" & @CRLF & _
"<p class="container" tabindex="2">hello, ma'am!</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")