const regex = /<[^>]+class="container"[^>]*>([^<]+)<\/[^>]+>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]+class="container"[^>]*>([^<]+)<\\\/[^>]+>', 'g')
const str = `<div class="container">div</div>
<span contenteditable class="container" id="a_span_element">nope!</span>
<span>Not matching</span>
<p class="container" tabindex="2">hello, ma'am!</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}