import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]+class=\"container\"[^>]*>([^<]+)<\\/[^>]+>";
final String string = "<div class=\"container\">div</div>\n"
+ "<span contenteditable class=\"container\" id=\"a_span_element\">nope!</span>\n"
+ "<span>Not matching</span>\n"
+ "<p class=\"container\" tabindex=\"2\">hello, ma'am!</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}