package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^>]+class="container"[^>]*>([^<]+)<\/[^>]+>`)
var str = `<div class="container">div</div>
<span contenteditable class="container" id="a_span_element">nope!</span>
<span>Not matching</span>
<p class="container" tabindex="2">hello, ma'am!</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}