$re = '/<[^>]+class="container"[^>]*>([^<]+)<\/[^>]+>/';
$str = '<div class="container">div</div>
<span contenteditable class="container" id="a_span_element">nope!</span>
<span>Not matching</span>
<p class="container" tabindex="2">hello, ma\'am!</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);