// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<[^>]+class="container"[^>]*>([^<]+)<\/[^>]+>"#).unwrap();
let string = "<div class=\"container\">div</div>
<span contenteditable class=\"container\" id=\"a_span_element\">nope!</span>
<span>Not matching</span>
<p class=\"container\" tabindex=\"2\">hello, ma'am!</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}