import Foundation
let pattern = #"<[^>]+class="container"[^>]*>([^<]+)<\/[^>]+>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="container">div</div>
<span contenteditable class="container" id="a_span_element">nope!</span>
<span>Not matching</span>
<p class="container" tabindex="2">hello, ma'am!</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)