# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\\/\\/[^\s]+[?&]v=([^&\s]+)[^\s]*/\1/gm;t' <<< "This text contain this link https://www.youtube.com/watch?v=b8ri14rw32c&rel=0 and so on..."