// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/\/[^\s]+[?&]v=([^&\s]+)[^\s]*").unwrap();
let string = "This text contain this link https://www.youtube.com/watch?v=b8ri14rw32c&rel=0 and so on...";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}