import Foundation
let pattern = #"https?:\/\/[^\s]+[?&]v=([^&\s]+)[^\s]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This text contain this link https://www.youtube.com/watch?v=b8ri14rw32c&rel=0 and so on..."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)