const regex = /https?:\/\/[^\s]+[?&]v=([^&\s]+)[^\s]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[^\\s]+[?&]v=([^&\\s]+)[^\\s]*', 'gm')
const str = `This text contain this link https://www.youtube.com/watch?v=b8ri14rw32c&rel=0 and so on...`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);