using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/[^\s]+[?&]v=([^&\s]+)[^\s]*";
string substitution = @"\1";
string input = @"This text contain this link https://www.youtube.com/watch?v=b8ri14rw32c&rel=0 and so on...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}