$re = '/https?:\/\/[^\s]+[?&]v=([^&\s]+)[^\s]*/m';
$str = 'This text contain this link https://www.youtube.com/watch?v=b8ri14rw32c&rel=0 and so on...';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;