#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?:\/\/[^\s]+[?&]v=([^&\s]+)[^\s]*"
Local $sString = "This text contain this link https://www.youtube.com/watch?v=b8ri14rw32c&rel=0 and so on..."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)