# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(\w+)\s\S+="([^\]"]*)"](.*?)\[\\/\1]//g;t' <<< "[code background=\"background.jpg\"] Here some text [/code]"