using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(\w+)\s\S+=""([^\]""]*)""](.*?)\[\/\1]";
string substitution = @"";
string input = @"[code background=""background.jpg""] Here some text [/code]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}