re = /\[(\w+)\s\S+="([^\]"]*)"](.*?)\[\/\1]/
str = '[code background="background.jpg"] Here some text [/code]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result