use strict;
my $str = '[code background="background.jpg"] Here some text [/code]';
my $regex = qr/\[(\w+)\s\S+="([^\]"]*)"](.*?)\[\/\1]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";