$re = '/\[(\w+)\s\S+="([^\]"]*)"](.*?)\[\/\1]/';
$str = '[code background="background.jpg"] Here some text [/code]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;