#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(\w+)\s\S+="([^\]"]*)"](.*?)\[\/\1]"
Local $sString = "[code background="background.jpg"] Here some text [/code]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)