import Foundation
let pattern = #"\[(\w+)\s\S+="([^\]"]*)"](.*?)\[\/\1]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[code background="background.jpg"] Here some text [/code]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)