#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bObject\s*=\s*(?<delimiter>["'])(?<value>.*?)\1"
Local $sString = "<Storages IP="192.168.0.29" Server="OPC.SimaticNET.S7OPT" Computer="WG-DE-D11001DS" Station="MIH-COMMON-0" SPS="MIH-COMMON-0-PLC" Object="OpcUa_MIH-COMMON-0-PLC" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")