$re = '/\bObject\s*=\s*(?<delimiter>["\'])(?<value>.*?)\1/m';
$str = '<Storages IP="192.168.0.29" Server="OPC.SimaticNET.S7OPT" Computer="WG-DE-D11001DS" Station="MIH-COMMON-0" SPS="MIH-COMMON-0-PLC" Object="OpcUa_MIH-COMMON-0-PLC" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);