use strict;
my $str = '<Storages IP="192.168.0.29" Server="OPC.SimaticNET.S7OPT" Computer="WG-DE-D11001DS" Station="MIH-COMMON-0" SPS="MIH-COMMON-0-PLC" Object="OpcUa_MIH-COMMON-0-PLC" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" />';
my $regex = qr/\bObject\s*=\s*(?<delimiter>["'])(?<value>.*?)\1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}