const regex = /\bObject\s*=\s*(?<delimiter>["'])(?<value>.*?)\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bObject\\s*=\\s*(?<delimiter>["\'])(?<value>.*?)\\1', 'gm')
const str = `<Storages IP="192.168.0.29" Server="OPC.SimaticNET.S7OPT" Computer="WG-DE-D11001DS" Station="MIH-COMMON-0" SPS="MIH-COMMON-0-PLC" Object="OpcUa_MIH-COMMON-0-PLC" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}