import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bObject\\s*=\\s*(?<delimiter>[\"'])(?<value>.*?)\\1";
final String string = "<Storages IP=\"192.168.0.29\" Server=\"OPC.SimaticNET.S7OPT\" Computer=\"WG-DE-D11001DS\" Station=\"MIH-COMMON-0\" SPS=\"MIH-COMMON-0-PLC\" Object=\"OpcUa_MIH-COMMON-0-PLC\" Comment=\"Lokaler OPC-UA Server\" Type=\"SimaticNET.S7\" Company=\"Coperion\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}