re = /\bObject\s*=\s*(?<delimiter>["'])(?<value>.*?)\1/m
str = '<Storages IP="192.168.0.29" Server="OPC.SimaticNET.S7OPT" Computer="WG-DE-D11001DS" Station="MIH-COMMON-0" SPS="MIH-COMMON-0-PLC" Object="OpcUa_MIH-COMMON-0-PLC" Comment="Lokaler OPC-UA Server" Type="SimaticNET.S7" Company="Coperion" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end