using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bObject\s*=\s*(?<delimiter>[""'])(?<value>.*?)\1";
string input = @"<Storages IP=""192.168.0.29"" Server=""OPC.SimaticNET.S7OPT"" Computer=""WG-DE-D11001DS"" Station=""MIH-COMMON-0"" SPS=""MIH-COMMON-0-PLC"" Object=""OpcUa_MIH-COMMON-0-PLC"" Comment=""Lokaler OPC-UA Server"" Type=""SimaticNET.S7"" Company=""Coperion"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}