#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\.((((c|C)(c|pp|xx|\+\+)?$)|((h|H)h?(pp|xx|\+\+)?$))|(ino|pde|proto|cu))$"
Local $sString = "./test/known_fail/addition.c" & @CRLF & _
"./test/known_fail/addition.C" & @CRLF & _
"./test/known_fail/addition.cpp" & @CRLF & _
"./test/known_fail/addition.cc" & @CRLF & _
"./test/known_fail/addition.c++" & @CRLF & _
"./test/known_fail/addition.cxx" & @CRLF & _
"./test/known_fail/addition.ino" & @CRLF & _
"./test/known_fail/addition.pde" & @CRLF & _
"test/known_fail/addition.proto" & @CRLF & _
"test/known_pass/addition.proto" & @CRLF & _
"" & @CRLF & _
"./test/known_fail/test.h" & @CRLF & _
"./test/known_fail/test.H" & @CRLF & _
"./test/known_fail/test.hpp" & @CRLF & _
"./test/known_fail/test.hh" & @CRLF & _
"./test/known_fail/test.h++" & @CRLF & _
"./test/known_fail/test.hxx" & @CRLF & _
"" & @CRLF & _
"./.git/objects/13" & @CRLF & _
"./.clang-format" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")