import Foundation
let pattern = #"^.*\.((((c|C)(c|pp|xx|\+\+)?$)|((h|H)h?(pp|xx|\+\+)?$))|(ino|pde|proto|cu))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
./test/known_fail/addition.c
./test/known_fail/addition.C
./test/known_fail/addition.cpp
./test/known_fail/addition.cc
./test/known_fail/addition.c++
./test/known_fail/addition.cxx
./test/known_fail/addition.ino
./test/known_fail/addition.pde
test/known_fail/addition.proto
test/known_pass/addition.proto
./test/known_fail/test.h
./test/known_fail/test.H
./test/known_fail/test.hpp
./test/known_fail/test.hh
./test/known_fail/test.h++
./test/known_fail/test.hxx
./.git/objects/13
./.clang-format
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)