use strict;
my $str = './test/known_fail/addition.c
./test/known_fail/addition.C
./test/known_fail/addition.cpp
./test/known_fail/addition.cc
./test/known_fail/addition.c++
./test/known_fail/addition.cxx
./test/known_fail/addition.ino
./test/known_fail/addition.pde
test/known_fail/addition.proto
test/known_pass/addition.proto
./test/known_fail/test.h
./test/known_fail/test.H
./test/known_fail/test.hpp
./test/known_fail/test.hh
./test/known_fail/test.h++
./test/known_fail/test.hxx
./.git/objects/13
./.clang-format
';
my $regex = qr/^.*\.((((c|C)(c|pp|xx|\+\+)?$)|((h|H)h?(pp|xx|\+\+)?$))|(ino|pde|proto|cu))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}