const regex = /^.*\.((((c|C)(c|pp|xx|\+\+)?$)|((h|H)h?(pp|xx|\+\+)?$))|(ino|pde|proto|cu))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\.((((c|C)(c|pp|xx|\\+\\+)?$)|((h|H)h?(pp|xx|\\+\\+)?$))|(ino|pde|proto|cu))$', 'gm')
const str = `./test/known_fail/addition.c
./test/known_fail/addition.C
./test/known_fail/addition.cpp
./test/known_fail/addition.cc
./test/known_fail/addition.c++
./test/known_fail/addition.cxx
./test/known_fail/addition.ino
./test/known_fail/addition.pde
test/known_fail/addition.proto
test/known_pass/addition.proto
./test/known_fail/test.h
./test/known_fail/test.H
./test/known_fail/test.hpp
./test/known_fail/test.hh
./test/known_fail/test.h++
./test/known_fail/test.hxx
./.git/objects/13
./.clang-format
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}