import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "R(\\[-?\\d+\\])C(\\[-?\\d+\\])|R(\\[-?\\d+\\])C|RC(\\[-?\\d+\\])";
final String string = "R\n"
+ "C\n"
+ "RC\n"
+ "RC[1]\n"
+ "RC[-1]\n"
+ "R[1]C\n"
+ "R[-1]C\n"
+ "R[1]C[1]\n"
+ "R[-1]C[1]\n"
+ "R[1]C[-1]\n"
+ "R[-1]C[-1]\n"
+ "R[foo]\n"
+ "C[foo]\n"
+ "R[foo]C\n"
+ "RC[foo]\n"
+ "R[foo]C[foo]\n"
+ "RC[0]\n"
+ "RC[0]\n"
+ "R[0]C\n"
+ "R[0]C\n"
+ "R[0]C[0]\n"
+ "R[0]C[0]\n"
+ "R[0]C[0]\n"
+ "R[0]C[0]\n"
+ "RC[99]\n"
+ "RC[-99]\n"
+ "R[99]C\n"
+ "R[-99]C\n"
+ "R[99]C[99]\n"
+ "R[-99]C[-99]\n"
+ "R[99]C[-99]\n"
+ "R[-99]C[99]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}