import re
regex = re.compile(r"R(\[-?\d+\])C(\[-?\d+\])|R(\[-?\d+\])C|RC(\[-?\d+\])")
test_str = ("R\n"
"C\n"
"RC\n"
"RC[1]\n"
"RC[-1]\n"
"R[1]C\n"
"R[-1]C\n"
"R[1]C[1]\n"
"R[-1]C[1]\n"
"R[1]C[-1]\n"
"R[-1]C[-1]\n"
"R[foo]\n"
"C[foo]\n"
"R[foo]C\n"
"RC[foo]\n"
"R[foo]C[foo]\n"
"RC[0]\n"
"RC[0]\n"
"R[0]C\n"
"R[0]C\n"
"R[0]C[0]\n"
"R[0]C[0]\n"
"R[0]C[0]\n"
"R[0]C[0]\n"
"RC[99]\n"
"RC[-99]\n"
"R[99]C\n"
"R[-99]C\n"
"R[99]C[99]\n"
"R[-99]C[-99]\n"
"R[99]C[-99]\n"
"R[-99]C[99]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")