#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+(?:\.\d+)?)?(?:\|\d+(?:\.\d+)?){0,4}$"
Local $sString = "5.01|76543|23343|4.32323|3" & @CRLF & _
"5.01" & @CRLF & _
"5.01|76543" & @CRLF & _
"5.01|76543|23343" & @CRLF & _
"5.01|76543|23343|4.32323" & @CRLF & _
"5.01,543,2343 " & @CRLF & _
"1|2|3|4|5|6" & @CRLF & _
"5.01|76543|23343|4.32323|3|5.4" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")