import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d+(?:\\.\\d+)?)?(?:\\|\\d+(?:\\.\\d+)?){0,4}$";
final String string = "5.01|76543|23343|4.32323|3\n"
+ "5.01\n"
+ "5.01|76543\n"
+ "5.01|76543|23343\n"
+ "5.01|76543|23343|4.32323\n"
+ "5.01,543,2343 \n"
+ "1|2|3|4|5|6\n"
+ "5.01|76543|23343|4.32323|3|5.4\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}