using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d+(?:\.\d+)?)?(?:\|\d+(?:\.\d+)?){0,4}$";
string input = @"5.01|76543|23343|4.32323|3
5.01
5.01|76543
5.01|76543|23343
5.01|76543|23343|4.32323
5.01,543,2343
1|2|3|4|5|6
5.01|76543|23343|4.32323|3|5.4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}