use strict;
my $str = '5.01|76543|23343|4.32323|3
5.01
5.01|76543
5.01|76543|23343
5.01|76543|23343|4.32323
5.01,543,2343
1|2|3|4|5|6
5.01|76543|23343|4.32323|3|5.4
';
my $regex = qr/^(?:\d+(?:\.\d+)?)?(?:\|\d+(?:\.\d+)?){0,4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}