$re = '/^(?:\d+(?:\.\d+)?)?(?:\|\d+(?:\.\d+)?){0,4}$/m';
$str = '5.01|76543|23343|4.32323|3
5.01
5.01|76543
5.01|76543|23343
5.01|76543|23343|4.32323
5.01,543,2343 
1|2|3|4|5|6
5.01|76543|23343|4.32323|3|5.4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);