// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d+(?:\.\d+)?)?(?:\|\d+(?:\.\d+)?){0,4}$").unwrap();
let string = "5.01|76543|23343|4.32323|3
5.01
5.01|76543
5.01|76543|23343
5.01|76543|23343|4.32323
5.01,543,2343
1|2|3|4|5|6
5.01|76543|23343|4.32323|3|5.4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}