#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*|\(([^()\r\n]+|(?>))\)"
Local $sString = "(C,D) (E,F) (G,H) (J,K)" & @CRLF & _
"(C,D) (E,F) (G,H) (J,K)" & @CRLF & _
"((C,D) (E,F) (G,H) (J,K)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)