const regex = /\s*|\(([^()\r\n]+|(?>))\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*|\\(([^()\\r\\n]+|(?>))\\)', 'gm')
const str = `(C,D) (E,F) (G,H) (J,K)
(C,D) (E,F) (G,H) (J,K)
((C,D) (E,F) (G,H) (J,K)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);