use strict;
my $str = '(C,D) (E,F) (G,H) (J,K)
(C,D) (E,F) (G,H) (J,K)
((C,D) (E,F) (G,H) (J,K)';
my $regex = qr/\s*|\(([^()\r\n]+|(?>))\)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";