re = /\s*|\(([^()\r\n]+|(?>))\)/m
str = '(C,D) (E,F) (G,H) (J,K)
(C,D) (E,F) (G,H) (J,K)
((C,D) (E,F) (G,H) (J,K)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result