import Foundation
let pattern = #"\s*|\(([^()\r\n]+|(?>))\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(C,D) (E,F) (G,H) (J,K)
(C,D) (E,F) (G,H) (J,K)
((C,D) (E,F) (G,H) (J,K)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)