import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(je|jé)";
final String string = "Aserejé, ja deje tejebe tude jebere\n"
+ "Sebiunouba majabi an de bugui an de buididipí\n"
+ "Aserejé, ja deje tejebe tude jebere\n"
+ "Sebiunouba majabi an de bugui an de buididipí\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}